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Panorama makes importing data to InView and StockView easy IF you follow the procedures care-
fully and pay close attention as you go along. Importing takes a little effort, but compared to re-
keying all of that data...!

The only InView and StockView files that you can or should import data to are Contacts, Equipment
and Catalogue. Importing of financial data is not supported. Very Big Tip §

STEP 1: PREPARING TO IMPORT DATA
Before you can move any data into a HindSight file, you must have the data in a usable format.
Imported data must be in a text, or ASCII, format. See the owners manual for the software from
which you are exporting the data to determine how to create an export file in a text format.

STErP 2: A NeEw PANORAMA FILE
The next step is to create a NEW Panorama file to temporarily hold your data for transfer into
InView or StockView. If Panorama is not already running open a new Panorama file by double-
clicking on the Panorama icon, otherwise choose Open File from the File menu.

In the resulting dialog window, click on Import, locate your text file in the window and click on
Open. A new Panorama file, named Untitled opens with your data displayed in rows and columns.

This is a good time to use Save and give the file a temporary name such as “Transit File.”

STEP 3: RE-FORMATTING THE DATA

CoMBINING DATA
The Contacts file combines first and last names into a single field. It also stores multiple lines of an
address in a single field. Data being imported from other databases which store this data in sepa-
rate fields must be combined. To do a nice neat job of it requires a crash course in Panorama equa-
tion writing. Keep reading. By the same token, image databases, especially older DOS based pro-
grams have captions split into several fields while the Catalogue stashes all the caption lines as
one.We’ll go through the modifications slowly.

ADDRESS FIELDS
Let’s assume your existing database had addresses divided into two fields. Panorama assigns let-
ters, A, B, C, etc., as temporary names of fields in a new file.

In your new Panorama file, address data from your old file was imported into fields, say, J and K.
To get the address into InView’s Contacts file correctly the data in these fields, J and K, needs to
be combined in a single field.

Click on the J field, making it the active field.
Select Formula Fill from the Math menu and enter the equation:

strip(J+1+K)

In a nutshell, this equation tells Panorama to add a carriage return and the contents of K to J. “strip”
removes any leading or trailing spaces or carriage returns to keep things tidy. Warning! »

Note: “q” is a carriage return is in computer language, telling Panorama that we want to add a

Return between J and K. On Macintosh it’s created by typing Option-7. On Windows it’s Alt+0182.
FIrRsT AND LAsT NAMES

Let’s suppose that the first and last names are in fields A and B.

Click on A to make it the active field.

Select Formula Fill from the Math menu and enter:

strip(A+" "+B)

In this case, the quotes with a space between them tell Panorama to literally add a space there. As
we did on the addresses we’re simultaneously stripping any leading or trailing spaces or carriage
returns to clean up the results as best we can.

If you have a third field for middle initials, let’s say it’s in C, the formula is simply expanded to:
strip(A+" "+C+" "+B)

When data is added from one field to another, it’s copied but not removed from the first field. To
empty a field holding information already combined into a single field, click on the field and choose
Fill from the Math menu. Enter nothing, click OK and the field is filled with nothing, aka: emptied.

Very Big Tip:
The HindSlght Extras
disk contains a file
named “Contacts
Utility"”. This utility pro-
gram can make it ex-
tremely easy to import
names and addresses
from mailing lists,
PDA's and from your
old software.

It even has some auto-
mated scripts for im-
porting from a few
specific products.

And, wouldn't you

know it also handles all
sorts of special Export
functions for Contacts.

It could allow you to
Ski? this whole chap-
ter!

Check our web site at
www.hindsightltd.com
. The Forums may
have some new infor-
mation and the
Download page may
have some new utili-
ties to make these
tasks easier.

Warning!

You might think this
formula didn't com-
bine the two ad-
dress lines. In a
Data Sheet window
you can only see the
top line of a cell.
Double click to open
a cell in field J, then
expand the cell’'s
height to view the
second line of ad-
dress.
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SAVE As vyou Go

After each step give your data a visual inspection. If things are looking good type Cmd/Ctrl-S to
preserve your work so far. Make a copy once in a while too, as an extra fallback position.

REVERT ToO SAVED

If something goes wrong, Undo in the Edit menu can go back one step for you. The ultimate Undo
is actually Revert to Saved in the File menu. This puts everything back to the way it was the last
time you saved. That’s why it’s good to save periodically as long as you’re well satisfied that every-
thing is right so far.

ExXTRACTING DAaTA

Equations are helpful in other changes. If you stored area codes and phone numbers in a single field
previously, you need to separate them now, for HindSight files. We’re going to give you one quick
example of taking a number apart to either get you going or totally intimidated.

Presume the phone number field, named F in the new Panorama file, contains phone numbers
entered in a variety of formats like (212) 664-3271 and 456-7890. Click on the field where you
want to put area codes and choose Formula Fill.

Enter:

F[II(II’II)II]
This extracts characters in field F from the first open parenthesis to the first close parenthesis.
Numbers in F without parentheses are ignored.

Next click on the field where you want to put the rest of the number. It can even be the field that
already contains the whole number, which in our example is field F.

Enter:
?(F contains ")",extract(F,")",2),F[-8,-1])

This extracts characters following “)” if a right parenthesis exists, otherwise it uses the eighth char-
acter from the end to the last, aka the last eight characters.

LEFTOVERS

In order to match file structures, you’re probably going to need to delete some fields altogether
before the data can be moved to your HindSight files. These would be fields that have no corre-
sponding field in the HindSight file to which the data is headed. Prior to deleting them, consider
where the data in those fields should be transferred if it has not been combined with other fields
already.

Tip: Contacts, Catalogue and Equipment each have a Comments field in which you can place this
otherwise unmatched data.

In your temporary Panorama file, a single field can serve as a temporary catch-all for data from
fields you need to delete. To transfer data into the catchall, use this equation.

strip(C+T1+G+1+M)
To include words that identify your data within the catch-all, add the words in quotes:

"Last Job "+G+1+"Volume "+J+1+Birthday "+M

This equation has a carriage return and, between the quotation marks, words to identify the data.
The wording between quotes will be literally added to the beginning of the named field’s data. Each
of these three pieces of data will get placed onto another line within the data cell due to the .

INSERTING FIELDS

If you need more fields in which to arrange your data, go to the Setup menu and choose Add Field.
A dialog opens for you to name the field and to indicate whether it should be added to the end of
the file or inserted in front of the active field.

NAMING THE FIELDS

If you have much database experience you’ve already recognized that Panorama’s equations are
powerful and fast. Now you’re really going to be impressed.

Once your data has been re-arranged within the fields, it’s time to re-name the fields themselves so
that the names match the field names of the HindSight destination file.

This is probably a good time to Save in order to preserve your efforts so far.




STEP 4:

Il m p o r t i

The fields with data destined for InView or StockView must be named to exactly match field names
in the destination file. Fields with unmatched names get ignored. Their sequence within the list does
not matter.

To rename a field, double-click on the field title. For instance, if the field bearing your contacts
names is currently titled D, double-click on D. A dialog window opens in which you can enter a
new field name. In this case you type Contact. Warning! p

Lists of the field names for Contacts, Catalogue and Equipment follow at the end of this chapter.
Fields to be imported from your temporary database must be named exactly the same as the fields
in these lists in which you want them to end up. It’s not necessary for you to have all of the fields
in these lists. You may only have one or two. If you have extra fields or fields with different names,
they get ignored during the import process. Warning! #

Note: The Field Names are not accessible in HindSight files because the access levels have been
locked down.

IMPORTING DATA

Open the recipient file, Contacts, Equipment or Catalogue, and select Open File from the File menu.
If you’re adding to records already there, click on Append to Current Database at the bottom of the
window. Otherwise click on Replace Current Database.

Click on the checkbox for Match Fields by Name.

Now locate and select the file that you just modified. Click on Open and the procedure is complete.

CHECK YOUR WORK

Before saving, open the Data Sheet of the InView or StockView file and scan through the fields to
see if things look like they’re where they belong. The Data Sheet is opened from the Windows
menu. If everything looks right, Save. Otherwise make note of the errors then go back and recheck
the field structure of your temporary file. To restore the HindSight file to its original condition use
Revert To Saved from the File menu or just close the file without saving.

SAVE YOUR WORK
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Warning!

It's not necessary to
assign other attrib-
utes in this window.
In fact, doing so
may disrupt the abil-
ity to finish the im-
porting process.
Just stick to the

Field Names.
Warning!

Each field in your
Transit Panorama file
must have a unique
name. Import does
not import data from
duplicate field
names. Remember
that extra fields can
be combined (see
Leftovers.)
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324 CoNTACTs FIELDS

Reading left to right:
Category Value Contact Company
Address City State Zip Code
Country Area Codel Phonel Memol
Area Code2 Phone2 Memo?2 Area Code3
Phone3 Memo3 Area Code4 Phone4
Memo4 Area Code5 Phone5 Memo5
Title Business Type Sources Salutation
TaxRate URL EMail Addresses Special Numbers
Eventl Eventl Notes Event2 Event2 Notes
Event3 Event3 Notes Shipping Accounts Comments
Notes Company Notes Meetings Phone Calls
Sales Calls Transactions Mailings Invoice to:
Inv Address Inv City Inv State Inv Zip Code
Inv Area Code Inv Phone Ship Address Ship City
Ship State Ship Zip Code Home Address Home City
Home State Home Zip Code Key Words DateNew
Updated Modified

CATALOGUE FIELDS

Reading left to right:
Caption Cross References Creator ©Year
Registration# MR MR# Generation
Format Medium Orientation Date Created
Date Entered File Location In/Out Serial A
SerialB Memo Value $Earned
Previous Use Restrictions Notes Quantity
Range Dupes Image Image Location

EQuiPMENT FIELDS

Reading left to right:
Item Manufacturer Model Serial Number(s)
Purchase Date Cost QTY Replacement Cost
Life Salvage Value Insured Basis
Insured Value Monthly Depreciation  Annual Depreciation ~ Warranty
Warranty Until Comments Category Repair Costs
Repair Comments Updated Tag New or Used
DateNew Modified Country Of Origin Weight

Carnet Value

CoNTACTS UTILITY

Check your HindSight Extras disk for a supplementary file named Contacts Utility. It greatly
expedites the process of getting data formatted and ready for importing into the Contacts file.
The file is also available in updated versions from the Downloads section of the HindSight
website, www.hindsightltd.com.

Check the Forums and the Downloads page for other utility files too.
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